Bau eines Schiffs (nicht schwer)



Erst einmal ein paar Informationen zum lesen


Auf manchen Systemen (Linux KDE/Gnome und SGI IRIX 4dwm) gibt es ein eigenes Programmicon fuer "dune4kids", es sieht dann irgendwie so aus:


Auf Systemen wie Micro$oft Windows oder MacOSX ist aber nur ein (anderes) Programmicon vorhanden:


Normalerweise startet das Programm dieses Icons beim ersten Mal in der englischen Vollversion, in der Regel mit sehr vielen Icons und zu vielen Menues.


Es muss dann zuerst einmal auf Deutsch und dann auf dune4kids umgestellt werden.
Man muss hier draufklicken um auf die richtige Version umschalten zu können.


Was tun, wenn das Programm abstürtzt ?

Mit etwas Glück kann man den letzten Stand neu laden, wenn man bei den aktuellen Dateien eine neue ".dune_crash" Datei findet.

Navigation

Navigation bedeutet das Herumbewegen im 3D-Modell.
Das ist wichtig, denn es kann sehr leicht passieren, dass man vor oder in sein Werkstueck gerät und deswegen ueberhaupt nichts mehr sieht.

Wenn man nichts mehr sieht, gibt es zwei Vorgehensweisen, die man meistens gemeinsam anwendet: Zusätzlich gibt es noch die Möglichkeit, die linke Maustaste, die "Shift"-Taste und die "Control"-Taste gleichzeitig gedrückt zu halten (oder das Icon benutzen). Damit kann man sich in Richtung der Bildschirmfläche, also nach oben, unten, links oder rechts bewegen.

Nachdem man sein Objekt wieder gefunden hat, sollte man wieder das "Examine"-Icon drücken, damit man wieder wie gewohnt arbeiten kann.

Icons für Veränderungen

Um zu zeigen, wie man Dinge verändern kann, wird einfach mal ein Quader erzeugt.


Icons, um ganze Objekte zu verändern: Mit weissen Kästchen kann man Objekte selber verändern. Mit den einzelnen Pfeilicons kann man die Richtung steuern.
Wird zum Beispiel nur der grüne Pfeil hereingedrückt, kann bei


ein Kästchen nur in Richtung des grüne Pfeils geschoben werden.
.

Genau wie man Pfeile auch an den Schäften statt an den Spitzen packen kann, um in einer Ebene verschieben zu können, kann man auch zwei Pfeile gleichzeitig hereingedrücken , um ein Kästchen in einer Ebene verschieben zu können.

Jetzt geht es los: Bau einer Schiffs (nicht schwer)


Die folgende Beschreibung muss man nicht sklavisch befolgen, aber (zumindest beim ersten Versuch) halbwegs in der Spur bleiben.

Ein Schiff wird aus mehreren Teilen hergestellt: einem Rumpf, einem Mast mit Maststange und einem Segel.

Rumpf


Begonnen wird mit dem Rumpf.
Für den Rumpf beginnt man mit einer Halbkugel Neu -> Halbkugel:

Eine Halbkugel wäre aber meistens zu langweilig.

Um eine bessere Form zu erreichen, muss muss man die Zahlen der Formel ändern, die die Form des Schiffs berechnet. Dazu benutzt man den Menüeintrag
Veraendern -> Zeige (manchmal) Zahlen:

Dabei kann man bei manchen angewählten Objekten im linken Fenster (hier "SuperShape") die Zahlen verändern.

Wenn man die Felder mit den Zahlen anklickt, kann man Zahlen eintippen (Achtung: "Kommazahlen" werden hier mit einem Punkt geschrieben).

Man kann auch die Zahlen verkleinern oder vergrößern indem man eine Zahl anklickt ohne die Maustaste loszulassen (dabei erscheint ein Doppelpfeil) und die Maus nach links oder rechts bewegt. Die Zahlen, die für eine Schiffsform benutzt werden können, sind eigentlich ziemlich egal. Allerdings mit einer Ausnahme: die Zahl für "um" sollte ungefähr 1 sein.
Wenn man sich mit den Zahlen total verhaspelt hat, kann man mit Veraendern -> Setze Startwerte wieder zu einer vollen Kugel zurül;ckkehren.

Sinnvoll ist, die Schalter für "top" (bzw. "bottom") anzuklicken. Dann hat das Schiff auch ein richtiges Deck und ist nicht hohl wie eine Nussschale.


Zieht man an einem weissen Kästchen, kann man den Körper viel gezielt verändern.
Beim white_dune Programm sind bestimmte Richtungen bevorzugt. Man kann zum Beispiel Körper mit dem Joystick steuern, wenn der Körper richtig liegt. Es gibt auch einen dazu passenden Bewegungsart -> Aufstehen Befehl.
Deswegen sollte man den Rumpf nur in Richtung des blauen Pfeils in die Läge ziehen.
Jetzt sollte man das Zwischenergebnis in eine Datei abspeichern. Beendet man das Programm (oder schaltet man den Strom ab) ist alles verloren, wenn man nicht in eine Datei abgespeichert hat. Zum Abspeichern benutzt man
Datei -> Speichern.
Dabei öffnet sich ein Fenster, an dessen unteren Rand man etwas eintippen kann. Am besten ist es, wenn man das Wort Schiff, dann einen Unterstrich (dieses Zeichen: _), dann seinen Vornamen, dann einen Unterstrich (_), dann seinen Nachnamen, dann einen Unterstrich (_) und dann sein Alter eintippt.

Also wenn man "Max Mustermann" heisst und 9 Jahre alt ist: Schiff_Max_Mustermann_9
Damit weiss man beim Zusammenbauen des Films, dass die Datei ein 3D-Modell eines Schiffs enthält und dass man "Max Mustermann, 9 Jahre" zum Schiff im Abspann schreiben muss.

Auch später (und vor allem am Schluss !) sollte man immer mal wieder Datei -> Speichern benutzen, damit nichts verloren geht.

Jetzt sollte das "Examine"-Icon hineingedrückt sein. Ausserdem sollte das Icon für "X gespiegeltes Verändern" hineingedrückt sein (ändert man ggf. mit Verändern -> "X gespiegeltes Verändern").

Mast


Beim Bau des Mastes muss man dafür Sorge tragen, dass der Mast mitbewegt wird, wenn man den Rumpf bewegt. Dazu muss das oberste Transform im linken Fenster angeählt werden.

Für die Maststange wird ein Zylinder mit Neu -> Zylinder eingefügt.

Leider ist der Zylinder viel zu dick. In der jetzigen Form ist er eher als Turm eines U-Boots benutzbar. Hier wäre deshalb der Punkt, an dem man vom Segelboot zum U-Boot umschwenken könnte. Allerdings muss man sich dann seine weiteren Objekte selber zusammensuchen. Zum Beispiel kann man Ruder/Flossen aus flachgeklopften Kugeln (bzw. Superegg) basteln (siehe oben Vergrössern/Verkleinern). Den Zylinder kann man mit den weissen Kächsten dünner machen. Genauso kann die Länge des Zylinders (also die Länge des Masts) verändert werden. Da die Länge des Masts oben und unten wächst, muss man oft auch die Höhenlage des Masts mit Hilfe des grünen Pfeils verändern.

Als nächstes ist die Querstange des Masts an der Reihe. Dazu wählt man den Transform-Befehl des Masts (hier also den zweitobersten Transform-Befehl im linken Fenster an.


Danach benutzt man Berarbeiten -> Kopieren und sofort danach (ohne irgendwas anderes anzuklicken) Berarbeiten -> gespiegelt einfuegen -> x (rot).
Jetzt existieren zwei Masten, aber weil sie an der selben Stelle stehen, sieht man nur einen.


Jetzt wählt man den Transform des neu entstandenen Masts an.

Mit dem Befehl Verändern -> setze Startwerte verschiebt man die Mastquerstange nach unten.

Man dem Befehl Verändern -> Vertauschen -> x (rot) und y (gruen) wird die Mastquerstange umgeklappt.

Danach muss man die Querstange mit Hilfe der Pfeile noch etwas weiter nach oben schieben.

Segel


Für das Segel wird wieder der oberste Transform im linken Fenster angewählt.

Mit Neu -> Flaeche wird das Segel eingefügt.

Allerdings ist das Segel falsch entstanden. Das wird mit Veraendern -> Vertauschen -> y (gruen) und z (blau) repariert. Danach kann man das Segel an die richtige Stelle schieben.

Mit dem Umschalten auf Vergrössern/Verkleinern

kann man die Grösse des Segels anpassen.

Danach klickt man das Segel an und klickt mit dem Mausrad (Mausrad drücken und loslassen) zwei Punkte in der Mitte des Segels an, so dass sie grün gefärben.

Indem man den blauen Pfeil am oberen Rand anklickt, stellt man sicher, dass die Punkte nur nach vorne oder hinten bewegt werden.

Dann schiebt man mit die Punkte nach vorn.

Damit ist das Schiff komplett.

Vorwärts

Jetzt kann man das Schiff endlich nach vorne schwimmen lassen.
Die folgenden Bilder zeigen aber einen Fisch und kein Schiff, obwohl im Text von einem Schiff die Rede ist.
Letztendlich ist aber völlig egal, was bewegt wird.

Es könnte auch ein Haus oder ein Baum sein, man würde immer gleich vorgehen. Die Bilder mit einem Fisch waren einfach schon fertig. 8-)

Zuerst muss man den Drehpunkt an die richtige Stelle setzen, sonst "schiebt" das Schiff um die Kurve.
Dazu wält man das oberste Transform im linken Fenster an und klickt auf das Icon für Drehpunkt verschieben.

Und schiebt den Mittelpunkt mit der Maus auf der Spitze des hellblauen Pfeils an die richtige Stelle.

Am besten benutzt man für schwimmenlassen einen Joystick (bzw. Gamepad), der mit Optionen -> InputDevice Einstellungen in der white_dune Vollversion eingerichtet wurde. Dann gibt es einige Icons mehr in der obersten Leiste. Die beste Einstellung für die Bewegung mit dem Joystick ist das Icon, das "schweben" bedeutet und ein bisschen wie ein Luftkissenboot von vorne aussieht.

Jetzt klickt man den obersten Transform im linken Fenster an und benutzt
Animation -> Neue Animation (Objekt z.B. Transform anwaehlen)

Beim folgenden Dialog-Fenster sind schon "translation" (Verschieben) und "rotation" (drehen) ausgewält, so dass man nur noch "OK" drücken muss.
Jetzt muss man nur noch die Icons in der untersten Leiste für "Aufnahme" (roter Kreis) und "Abspielen" (blaues Dreieck) hineindrücken und kann die Bewegung des Schiffs, der mit dem Joystick gesteuert wird, aufzeichnen lassen.
Man sollte immer nur ein Animationsfenster mit Animationsdaten füllen und nicht Animationsdaten überschreiben, denn bei langsamen Maschinen kommt es dann leicht zum Ruckeln.

Wenn man sich vertan hat (passiert oft) kann man im Animationsfenster einen Bereich auswählen (mit dem Drücken und Festhalten der linken Maustaste und dem Verschieben der Maus in Richtung der Breite des Fensters) um mit sofortigem Bearbeiten -> Löschen einen Bereich der Animation zu löschen. Benutzt man nicht sofort Bearbeiten -> Löschen, sondern klickt was anderes an, wird was anderes gelöscht (zum Glück gibts Bearbeiten -> Rueckgaengig machen).
Geschafft !