"White_dune" was ist das ?

White_dune ist ein graphischer VRML97/X3DV Editor, ein simpler (NURBS) 3D Modeller und ein Animationwerkzeug in Entwicklung.
Es kann ein VRML97/X3DV file lesen, stellt dessen Szenengraph dar und erlaubt es dem Benutzer, den Szenengraph, die Fieldwerte und Routes zu verändern.
White_dune kann benutzt werden, um 3D-Modelle, Animationen und Interaktionen in VRML97/X3DV zu verbessern oder zu erstellen.
Als einziges 3D Modelling Werkzeug ist es verglichen mit der Konkurrenz noch etwas schwach. Es ist sinnvoll, noch zusätzlich einen statischen 3D Modeller mit VRML97/X3D Export (wie z.B. wings3D oder Art Of Illusion) einzusetzen.
Der Vorteil von white_dune gegenüber den meisten anderen 3D Modellern ist, dass das Beleuchtungsmodell und der innere Aufbau von white_dune auf den VRML97/X3DV Standards basiert. Dadurch lassen sich die Möglichkeiten von VRML97/X3DV bei einer Nachbearbeitung oder Erstellung mit white_dune besser nutzen.
Verglichen mit den allgemein einsetzbaren 3D Modellern (die meinstens nur Mesh (IndexedFaceSet) und Interpolatorknoten exportieren koennen) unterstützt white_dune alle VRML97 Knoten und alle Knoten des X3D Standards "X3D 3.2" (ISO/IEC 19775-1:2008), auch wenn nicht alle Knoten dargestellt werden.

"White_dune" abgestürzt, bisherige Arbeit verloren ?

White_dune wird dauernd weiterentwickelt und läuft daher nicht immer so stabil, wie es sollte.

Wenn white_dune abgestürzt ist, ist die bisherige Arbeit verloren ?

Nein, nicht zwingend.

"white_dune" versucht noch, die VRML97/X3D Datei kurz vor dem Absturz zu speichern. Das funktioniert nicht immer, vor allem wenn der Fehler, der den Absturz verursacht hat, die interne Datenstruktur zerstört hat (das passiert allerdings eher selten). Wenn die Datei erfolgreich geschrieben worden ist, schreibt white_dune unter Unix/Linux

   Internal Crash !
   Try to save Files
   attempt to write file to /home/someone/.dune_crash_NUMBER_NUMBER.wrl
   write sucessfull
auf die Standartfehlerausgabe des white_dune starteten Fensters und auf die Systemkonsole (z.B. das Fenster der "xconsole" Anwendung).
Die wichige Zeile ist dabei die Zeile "write successfull" ("erfolgreich geschrieben").
Unter M$Windows erscheint (ggf. nach Drücken von "ignorieren/ignore", falls man nach einer Debugger gefragt wird) eine entsprechende Messagebox

Wenn sie dann white_dune neu starten und das file Menü öffnen, sollten Sie den Dateinamen des .dune_crash Files sehen.

Klicken Sie darauf und speichern Sie in eine andere Datei.

Wenn der Fehler, der zum Absturz geführt hat, die interne Datenstruktur im Programm beschädigt hat, kann diese Methode versagen.
In diesem Fall lohnt es sich nach temporären Daten (".dune_*") im Verzeichnis der VRML-Datei zu suchen, die bei der Ausführung von Datei->Vorschau oder Datei->Textedit entstanden sind.
Diese Dateien werden bei einem normalen Programmende gelöscht, nicht aber bei einem Programmabsturz.
Wenn white_dune sehr oft abstuertzt, aber alle Daten erfolgreich gerettet werden konnten, kann es Sinn machen, diese überflüssigen Datein zu suchen und löschen, um verschwendeten Plattenplatz zurückzugewinnen.
Neben Dateien zur Vorschau und zum Editieren mit einem Texteditor speichert white_dune auch den Inhalt eines editierten Script-Knotens zur Verwendung in einem Texteditor in temporären Dateien.

"White_dune" mit deutschen Menues starten

Um white_dune mit deutschen Menues zu starten, muss die Kommandozeilenoption "-german" benutzt werden. Currently 3 commandlineoptions for languages are available:


Da es unpraktisch ist, das dauernd in eine Kommandozeile einzutippen, gibt es einen zweiten Weg, um die Sprache auszuwaehlen. Unter Linux/UNIX wird das über die Umgebungsvariable LANG erledigt. Wenn die ersten beiden Zeichen dieser Umgebungsvariable "de" ist, werden deutsche Men&umml;s benutzt, sind sie "it", werden italienische Men&umml;s benutzt.
Wenn man mit einer deutschen Umgebung arbeiten will, bei der $LANG entsprechend gesetzt ist, man aber trotzdem mit englischen Menüs arbeiten will, muss man die -english Kommandozeilenoption benutzt werden.
Das kann das über ein Shellskript (Linux/UNIX/MacOSX) oder Batchfile (M$Windows) gemacht werden.
Wenn Sie kein entsprechendes File (z.B. "germandune") finden, können Sie sie sich eines mit den Kommandozeilen: anlegen. Für MacOSX können Sie in der Datei white_dune.app/Contents/MacOS/dunestarter die Zeilen mit den Optionen für den Programmstart
   DUNEOPTIONS=" "
   export DUNEOPTIONS
um die -german Option ergänzen:
   DUNEOPTIONS="-german "
   export DUNEOPTIONS
Für andere exotische UNIX desktops finden sich entsprechende Optionen in den folgenden Dateien: Auf ähnlicher Weise ist es möglich, andere Kommandozeilenoptionen von white_dune zu benutzen. Die man page von white_dune (in englischer Sprache) zeigt andere Optionen.
Die wichtigsten Optionen sind: Die Menüs und Dialoge von white_dune können in andere Fremdsprachen übersetzt werden, ohne dass besondere Programmierfähigkeiten benötigt werden.
Wenn Sie sich dafür interessieren, die Menues und Fehlermeldungen von white_dune in ein neue Fremdsprache zu übersetzen (dazu sind keine Programmierfähigkeiten notwendig), dann lesen Sie bitte das Schritt fuer Schritt Kochrezept in englischer Sprache in der Entwicklerdokumentation.

Was bedeuten Szenengraph, Fieldwerte und Routes usw. ?

White_dune (ohne -4kids oder -4catt option) ist ein Lowlevel Werkzeug zum Bearbeiten von VRML97 und X3DV Files. Dabei wird vorausgesetzt, dass dem Benutzer die grundlegende Struktur von VRML/X3D bekannt ist.
Natürlich kann white_dune dazu benutzt werden, um sich in VRML/X3D einzuarbeiten. Ein guter Startpunkt ist natürlich das "-4kids" Kommandozeilenargument, aber damit lassen sich nur 3D-Objekte erzeugen und animieren, die interessanteren VRML/X3D Features wie Interaktion und Scripting bleiben aussen vor.

Man findet einige typischen VRML/X3D Beispiele (die man in white_dune) laden kann hier, aber man muss sich darüber im Klaren sein, dass diese Beispiele keine Modelling- oder Animations-Features zeigen, sie zeigen hauptsächlich VRML97 Beispiele mit Interaktion und Scripting. Das sind Features die in white_dune (noch) nicht korrekt angezeigt werden können.
Die Beispiele dienen als Ausgangsbasis, um mit white_dune interaktive 3D-Welten zu erstellen, die dann später mit einen "richtigen" VRML/X3D Browser angezeigt werden können.
Das "Route"-Fenster und der Script-Code sind für einen Anfäger am interessantesten.

Ausführliche technische Informationen zu VRML97 findet man in der offiziellen ISO Spezifikation unter http://www.web3d.org/x3d/specifications/vrml/ISO-IEC-14772-IS-VRML97WithAmendment1. Für die Benutzung von White_dune ist vor allem die Node Referenz http://www.web3d.org/x3d/specifications/vrml/ISO-IEC-14772-IS-VRML97WithAmendment1/part1/nodesRef.html wichtig.
X3D ist der Nachfolger von VRML97. Trotz einigen minimalen technischen Unterschieden (die von white_dune automatisch abgehandelt werden) sind alle Befehle des VRML97 Standards von 1997 in X3D weiter vorhanden.
Für den "vergessenen" VRML97 Amendment 1 Standard von 2002 gilt dies nicht z.B. der CoordinateDeformer Knoten existiert nicht mehr in X3D. Die meisten weiter existierenden VRML97 Amendment 1 Befehle werden aber automatisch von white_dune abgehandelt, wenn eine VRML97-Datei als X3D(V)-Datei abgespeichert wird.

X3D compiler und Open Wonderland Unterstützung

White_dune kann die Daten des VRML97/X3DV Szenengraphen in den Programmiersprachen C, C++ oder java exportieren ("X3D-compiler").
Details dazu findet man in der Manpage von white_dune.
Fuer die Programmiersprache C gibt es eine in der Entwicklung befindliche Bibleothek, mit deren Hilfe man 3D-Objekte und Animationen mit Hilfe von OpenGL rendern kann. Beispiele dazu finden sich im Verzeichnis docs/export_example_c des Sourcearchives. Die entsprechenden Beispiele fuer die Programmiersprache C++ finden sich im Verzeichnis docs/export_example_c++.
Fuer die Programmiersprache java existiert eine Möglichkeit, 3D-Objekte und Animationen mit der Java Monkey Engine (JME, Version 2) zu rendern.
Die entsprechenden Beispiele finden sich im Verzeichnis docs/export_example_java.
Darauf basiert auch der in white_dune eingebaute Export zu Quellcode für ein Module in Open Wonderland(einer Internet-3D-Multiuserumgebung).
Dabei ist neben der Anzeige von 3D-Objekten und Animation auch Interaktion (mit Hilfe der VRML97/X3D Sensorknoten) möglich. Allerdings werden (bisher) nicht alle X3D Knoten und nicht das gesamte Laufzeitverhalten unterstützt.
Im Gegensatz zu VRML/X3D und traditionellem OpenGL unterstützt Open Wonderland keine graphischen 3D-Objekte, die aus Polygonen mit mehr als 3 oder 4 Eckpunkten bestehen (obwohl Open Wonderland intern OpenGL verwendet). Deshalb trianguliert white_dune diese Objekte beim Wonderland-Export.
Das funktioniert aber nicht so einfach bei der Morphing-Animation von 3D-Objekte mit Polygonen mit mehr als 4 Eckpunkten, diese 3D-Objekte unterstützen beim Open Wonderland Export keine Morphing-Animation.
Ob ein bestimmter X3D Knoten in Open Wonderland unterstützt wird, sieht man am rechten unteren Rand seines Icons: dort befindet sich ein kleiner blauer Punkt (wie beim Icon für Box)

wenn der Knoten in Open Wonderland unterstützt wird.
Die Frage, welche Interaktionen möglich sind, entscheidet sich im RouteView-Fenster. Bei SensorKnoten und Interpolatoren (nur bei diesen) sind die unterstützten Events farbig markiert.
Eine blaue oder lila Markierung der Events eines Knotens im RouteView bedeutet, dass der Event vom Wonderland Exporter unterstützt wird, während eine rote oder keine Markierung bedeutet, dass der Event vom Wonderland Exporter (noch) nicht unterstützt wird. Eine rote Markierung bedeutet, dass es sich um einen oft benutzen Event handelt, eine lila Markierung soll eine Mischung zwischen roter und blauer Markierung andeuten: diese Events sind sowohl oft benutzt als auch vom Wonderland Exporter unterstützt.
Im Beispiel wird ein TouchSensor im RouteView-Fenster gezeigt, zusammen mit einigen seiner EventNamen.

Es kann zum Beispiel ein Route-Informationsverbindungsweg vom TouchSensor.isActive Event (blau markiert) zu einem ScriptKnoten geführt werden, um von dort Information mit einem kleinen, selbstgeschriebenen java-Programm in einem anderen Event eines anderen von Wonderland unterstützten Knoten zu leiten.
Es kann zum Beispiel auch ein Route-Informationsverbindungsweg von TouchSensor.touchTime (lila markiert) in einen TimeSensor.set_startTime Event (übrigens auch lila markiert) geführt werden, um damit eine einfache Animation zu starten (denn einfache Animationen in X3D bestehen auch den ROUTE Befehlen "TimeSensor (ggf. mit Feld loop FALSE) -> Interpolator > animierter Knoten").
Der Event TouchSensor.hitPoint_changed (rot markiert) wird zwar in X3D oft benutzt, wird aber nicht vom Wonderland-Export unterstützt.

Was "white_dune" nicht kann und was es kann

Die 5 Fenster von "white_dune"


Neben diversen Toolbars für Icons und Nachrichten besteht "white_dune" (ohne die -kids oder -4catt Startoptionen) im wesentlichen aus 5 Fenstern. Ausser dem "3D Preview" Fenster lassen sich die Fenster über den Menüpunkt "View" angepasst an den jeweiligen Arbeitsschritt ein- und ausschalten.

Überblick übers Menü

The main menu of white_dune is seperated into the following submenus:

Navigation

Um im 3D Preview Fenster navigieren zu können steht zur Verfügung:

zusätzlich steht ab der Version 0.16 eine SGI artige Navigation zur Verfügung. Bitte beachten Sie, dass es nicht selten ist, dass ein entsprechend konfigurierter Windowmanager diese Eingaben für seine eigenen Zwecke interpretieren könnte... Ist ein 6D Eingabegerät aktiv, kann bei angewähltem Scene-Icon im Scene Tree Fenster je nach der Auswahl der Transformicons durch das VRML File navigiert werden.
Das Scene-Icon wird ausgewählt, wenn ins Leere des 3D Preview Fensters geklickt wird.
Zusätzlich existiert je ein Icon das Navigation mit der Maus oder dem Eingabegerät erzwingt.

Verändern des Szenengraph

Einen neuen VRML node mit eine Mausklick auf das entsprechenden Icon hinzufügen ist der einfachste Weg, den Szenengraph zu ändern.
Um ein VRML Knoten Icon zu identifizieren, bewegen Sie den Mousezeiger über das Icon und warten Sie kurz. Ein beschreibender Text wird auf der Statusbar am unteren Ende des Fensters erscheinen.
White_dune versucht, entweder den neuen node am blau untermalten Selektionspunkt des Szenengraph

oder am root node des Scenengraph ("Scene" Icon) einzufügen.
White_dune graut alle node Icons aus, die nicht eingefügt werden können.


Die folgende Tabelle zeigt die Anforderung für die entsprechenden Knoten im VRML97 Standard:

So muss zum Beispiel ein Appearence Knoten selektiert sein, damit ein ImageTexture Knoten eingefügt werden kann, oder ein Shape Knoten selektiert sein, damit ein Appearence Knoten eingefügt werden kann.
Alle die entsprechenden Felder im VRML97 Standard sind vom Datentyp SFNode, deshalb kann nur ein Knoten eingefügt werden. Deshalb wird ein Icon auch dann ausgegräut, wenn schon ein entsprechender Knoten vorhanden ist.
Zum Beispiel können keine zwei ImageTexture Knoten zu einem Appearence Knoten hinzugefüt werden. Deswegen ist das ImageTexture Icon ebenfalls ausgegraut, wenn ein Appearence Knote selektiert wird, aber ein ImageTexture Knoten schon vorhanden ist.
Nach dem VRML97 Standard brauchen auch die Körper Knoten Box, Sphere, Cone, Cylinder, IndexedFaceSet, IndexedLineSet, PointSet, ElevationGrid, Extrusion und Text als Vorraussetzung einen Shapeknoten. Da bei der Benutzung dieser Shape.geometry Knoten die benötigte Struktur klar ist, wird beim Klicken auf die Icons und bei der Benutzung der Erzeugen -> Koerper -> Menüpunkte eine vollständige Shape-Struktur (einschliesslich default Appearance/Material Knoten und einem umschliessenden Transform Knoten) aufgebaut.
(Neu in Version 0.29beta) Ist bei der Erzeugung so eines Shape-Knotens kein Knoten angewählt in den der Shape-Knoten passt, so wird der umschliessende Transform Knoten so aufgebaut, dass der neue Knoten direkt vor dem aktuellen Kamerapunkt erscheint).
Für die im VRML97 Amendment 1 Standard hinzugekommenen, aber inzwischen veralteten Knoten gilt zusätzlich: Die Erweiterungen und zusätzlichen Knoten des immersiven Cover VRML97 Browsers brauchen ebenfalls zusätzliche Regeln: Die Erweiterungen und zusätzlichen Knoten der kambi VRML game engine braucht auch eine zusätzliche Regel: White_dune hat selbst eine Scripted PROTO Erweiterung, die auch eine zusätzliche Regel braucht: Weil es sehr viel mehr X3D Knoten als VRML97 Knoten gibt, ist die Liste der benötigten Knoten bei X3D sehr viel länger als bei VRML97: Zusätzlich dazu gibt es noch die Regeln fuer die X3D Knoten der Rigid Body Physics Kompontente, die getrennt aufgelistet werden, da diese Regeln allein für eine sinnvolle Benutzung dieser Knoten nicht ausreichen: Diese Regeln reichen deshalb nicht aus, weil eine sinnvolle Anwendung den Aufbau einer Struktur erfordern, bei der CollideableShape und CollideableOffset Knoten im Wurzelknoten des Szenengraphen stehen und in verschiedenen Knoten ge-USE-d werden, die dann ihrerseits in weiterer Stellen ge-USE-d werden. Um die Erstellung dieser Struktur zu vereinfachen, gibt es eine entsprechende Operation f&umml;r Szenengraphzweige.

Die Kommandos Bearbeiten -> kopieren, Bearbeiten -> einfügen und Bearbeiten -> löschen arbeiten so wie die gleichen Kommandos in vielen Programmen.
Natürlich sind nur Änderungen des Szenengraphen möglich, die den oben vorgestellten "Knoten A braucht Knoten B"-Regeln entsprechen. Je nach selektiertem Knoten im Szenengraphen (dem Ziel einer Bearbeiten -> einfügen Aktion) wird also der Menüpunkt Bearbeiten -> einfügen ausgegraut oder nicht.
Es kann vorkommen, dass es bei einem unveränderten Szenengraphen nicht sofort möglich ist, einen kopierten Knoten einzufügen, weil ein Knoten fehlt, der zum Kopieren dieses Knotens gebraucht wird. Dieser fehlende Knoten muss dann zuerst neu erzeugt werden, bevor die Kopieraktion erfolgreich beendet werden kann.

Ein ungewöhnliches Kommando ist das Bearbeiten -gt; Kopiere Zweig bis zur Wurzel Kommando. Es kopiert alle Knoten entlang des Pfads bis zur Wurzel des aktuellen Szenengraph Zweigs in den Einfügen-Puffer.
Das kann sehr nützlich sein, um einen Szenengraphzweig zu duplizieren und aufzuspalten.

Ein anderer Weg, den Szenengraph zu verändern, ist Teile davon mit der Maus herumzuschieben.
White_dune zeigt das Icon eines Stopschildes, wenn der Zielknoten dies wegen der "fehlenden Knotenregel" nicht erlaubt.

Wenn der Zielknoten es erlaubt, benutzt white_dune den normalen Mauszeiger.

Ein Ziel ist nicht eindeutig, wenn der Ziel node mehrere SF/MFNode fields hat.

Knoten mit mehreren Fields vom Typ SF/MFNode (zum Beispiel der collision Knoten) werden im Scenetree immer mit den entsprechenden Feldnamen dargestellt (auch wenn die Einstellungen im Optionen -> Allgemeine Einstellungen... Dialog anders sind), damit die Field Namen als Ziel benutzt werden können.

Genauso wie beim lokalen kopieren/verschieben im Explorerprogramm von M$Windows2000 und ähnlichen Filemanagern kann man das Verhalten beeinflussen, wenn man die Tastatur benutzt, nachdem man angefangen hat, den VRML Knoten herumzuschieben:

Die Benutzung von USE

(neu in Version 0.29beta)
Neben der oben gezeigten drag and drop Methode gibt es einen weiteren Weg um das USE Konstrukt zu benutzen. Der Knoten, der ge-USE-t werden soll braucht einen DEF Namen, der mit Bearbeiten -> DEF zugewiesen wird. Bearbeiten -> USE (falls möglich) erzeugt ein neues USE des letzten ge-DEF-ten Knotens an der Stelle des angewählten Knotens.
In white_dune (anders wie wenn man einen Texteditor für eine VRML97 Datei benutzt), kann man den ge-DEF-ten Knoten problemlos löschen. Der zuerst geschreibene ge-USE-te Knoten wird dann zum neuen ge-DEF-ten Knoten.
Die Benutzung von USE ist sinnvoll, um VRML Dateien klein zu halten (was bedeutet, dass die Dateien schneller im Internet ü:bertragen werden können), erhöht die Wartbarkeit und kann unter Umständen von einem geschickt programmierten VRML Browser dazu genutzt werden, dass Objekte schneller gezeichnet werden (zum Beispiel durch die Verwendung von glLists bei OpenGL rendering).
Zusätzlich Kommandos die USE benutzen sind das array Werkzeug und manche der folgenden "create" Szenegraph Operationen.

Szenengraph Operationen

(new in Version 0.27beta)
Es gibt (noch) keinen Weg, um mehrere Knoten im Szenengraph zu verschieben. Als Workaround gibt es Operationen um den aktuellen Szenegraphzweig umzusortieren (Aktion -> bewege Geschwisterknoten -> nach oben/nach unten/zur ersten/letzten Position) und Operationen, die auf alle Knoten im Szenengraph Zweig wirken, der dem angewälten Knoten folgt (einschliesslich des angewälten Knotens).

Die verfügbaren Kommandos sind Sie unter dem Menupunkt Aktion -> Rest des Szenegraph-Zweigs erreichbar: Leider sind einige dieser Operationen (noch) sehr langsam.

Eingabe/Löschen von ROUTE's

In white_dune gibt es zwei verschiedene Einstellungen, die entscheiden, wie eine ROUTE eingegeben werden kann.

ROUTEs werden in white_dune angelegt, indem man das entsprechende Icon im RouteView Fenster findet (klicken auf die Icons selektiert die entsprechenden Icons im Scene Tree Fenster) oder mit Route -> Zeige Knoten ganz oben im RouteView Fenster erscheinen läßt und auf die Kästchen für die Events klickt. Dabei wird der Name des Events angezeigt und es lässt sich eine Linie zum nächsten Icon/Event ziehen.

Es können (wie im VRML Standard verlangt) nur Events mit gleichen Datentypen (gleiche Farbe der Kästchen) verbunden werden.
Zum Löschen der ROUTEs kann die Linie einfach durchgestrichen werden.

Als Vorschlag für Anfänger sind einige Event-Kästchen mit einem kleinen roten Punkt markiert. Der rote Punkt zeigt wichtige/oft benutzte Events.
Natürlich hängt die Wichtigkeit/Benutzungshäufigkeit eines Events vom Thema der VRML Welt ab. Alle Sensor Knoten (die eigentlich Quelle bei der Verarbeitung der meisten Events) haben mit roten Punkten markierte Event-Kästchen.

Bei komplexen VRML Welten mit vielen Objekten (zum Beispiel dem VRML Export aus einem 3D-Modelling-Programms wie Wings3D, Blender, AOI, Catia, 3D Studio Max, Maya usw.) kann es sehr schwierig werden, die gewüschten VRML Knoten im RouteView Fenster wiederzufinden.

Es gibt Befehle, um zum angewälten Knoten zu springen (mit Routes -> Kein Zoom/Sprung zur Auswahl)

oder die Ansicht des Routeview zu vergrössern (mit Routes -> Herauszoomen)

aber in diesem Fall empfiehlt sich der Einsatz des Inline VRML-Knotens. Damit ist es möglich ist statische Objekte (die zum Beispiel Teil der Umgebung oder Teil von starren Objekten sind) in eigene VRML Dateien auszulagern, so dass die gesamte VRML-Welt nur noch aus sehr wenigen VRML Knoten besteht.

Befehle, die automatisch ROUTEs erzeugen
Es gibt zwei Befehle, die automatisch neue ROUTEs erzeugen.

Fieldwerte verändern

Es gibt mehrere Möglichkeiten, Fieldwerte zu verändern:

Vereinfachtes Skriptbau-Verfahren (neu in Version 0.22beta)

Bevor man den Scripteditor Dialog benutzen kann, muss man planen, welche Datentypen und eventIn/eventOut Informationen die Knoten haben, die man anschliessen will. Dazu muss man die Knotenbeschreibung des VRML standards (zum Beispiel über den Menüpunkt Hilfe -> Name des gerade selektierten Knoten lesen (oder ein entsprechendes Buch benutzen).
Zum schnellen Ausprobieren kann es dagegen angenehmer sein, das vereinfachte Skriptbau-Verfahren zu benutzen.
Erzeugen Sie einen "leeren" Scriptknoten mit dem "Script" icon (oder benutzen Sie den Menüpunkt Erzeugen -> Programmierung -> Script).
Gemäss der "Weg da!" Philosophie des ursprünglichen dune Projekts drücken Sie einfach nur "OK" im Scripteditor Dialog (siehe oben).
Jetzt wird das RouteView Fenster für die weitere Arbeit benutzt.



Scriptknoten haben ein spezielles "connect anything" ("verbinde alles") eventOut. Wenn man draufklickt, die Maustaste festhält und die Maus verschiebt ("drag") wird eine weisse Route gezeichent



Wenn man die Maustaste gedrückt hält, kann man sehen, dass man diese Route (wie beim "normalen" Routing) an eventIns anderer Knoten anschliessen kann,



dass aber (im Gegensatz zum "normal" Routing) die Farbe dieser Route (also eigentlich der Datentyp) mit dem abgefragten eventIn wechselt.



Wenn man die Maustaste loslässt, wird die Route vollendet.



Entsprechend lässt sich der spezielle "connect anything" eventIn des Scriptknotens benutzen



und mit dem eventOut eines anderen Knoten verbunden.



Jetzt müssen Sie noch das "url" Feld des Scriptknoten verändern. Neben der Benutzung von urledit können sie auch den Scriptknoten im SceneTree Fenster und das "url" Feld im FieldView Fenster selektieren und dann



das "Object Edit" Icon drücken (oder benutzen den Menüpunkt Aktion -> Objekt editieren).



Nun wird "white_dune" versuchen einen externen Editor zu starten - eingefleischte UNIX Benutzer benutzen "xterm -e vi", das ist der Default unter Linux/UNIX ("xedit" für MacOSX, "edit" für M$Windows) wenn $WINEDITOR nicht beim ersten Programmlauf gesetzt war. Man kann die Editoreinstellung mit dem Options -> Texteditor Settings ... Menüpunkt ändern.
Im Edit Fenster sehen Sie ein Schema des benötigten javascript Codes.

Benutzen Sie den Editor, um den Javascript code zu vervollständigen, dann speichern und verlassen Sie den Editor - im Fall des vi Editors benutzen Sie die Tastenkombination :wq
Benutzen Sie Options -> ECMAscript settings um einzustellen, welche erweiterten Kommentare Sie im Schema haben wollen.
Per default werden sehr viele Kommentare in das Skript geschrieben. Das ist zwar sehr nützlich für Anfänger, weil dann sofort alle mit den benutzten Datentypen möglichen Befehle schon im Script bereitstehen. Allerdings ist es auch ziemlich unübersichtlich.
Benutzer mit etwas Programmiererfahrung tendieren dazu, die Einstellungen in Options -> ECMAscript settings so zu setzen, dass nur der fest verdrahte Kommentar über den jeweils benutzen Datentyp übrig bleibt.

NURBS Modellierung (zum Teil neu in Version 0.25beta)

Superformula Modellierung (neu in Version 0.27beta)

Superformula Grundlagen

White_dune unterstützt 3D-modelling, die auf der sogenannten "superformula" ("Superformel") basiert.

        pow(pow(fabs(cos(m * angle / 4.0) / a), n2) + 
            pow(fabs(sin(m * angle / 4.0) / b), n3), -1.0 / n1)

Diese Formel wurde vor einigen Jahren von einem Biologen gefunden und kann benutzt werden, um n-symetrische Formen zu erzeugen, die Dingen aus der Natur wie Blumen, Blaettern, Insektenkörpern, Muscheln oder Seesternen ähnlich sehen.



Diese Formen wurden alle mit dem SuperShape PROTO erzeugt.

Superformula basierte Formen sind nicht von sich aus Teil von VRML97, sondern sind über ein PROTO (selbst definierter VRML Knoten) mit Scriptcode ("scripted PROTO") implementiert.
Superformula basierte Körper können entweder in einen Extrusion Knoten oder in einen IndexedFaceSet Knoten umgewandelt werden. IndexedFaceSet basierte superformula Körper können auch einem Nurbs(Patch)Surface Knoten angenähert werden, um so einen Startpunkt für weiteres NURBS-modelling zu haben.

Subdivide Modellierung (new in Version 0.99pl624)

Subdivide Modellierung ist verfügbar via actions -> subdivide Kommando oder drücken von "s" wenn ein mesh basierter Knoten (z.B. IndexedFaceSet, Box oder NurbsSurface) ausgewäht ist. Subdivide benutzt den Catmull-Clark Algorithm um Objekte weicher zu machen.
Starten Sie mit einer ausgewähten Box mit passender Größe:



Benutzen Sie Aktion -> subdivide oder drücken Sie "s"



Benutzen Sie Auswahl -> Flächen und ziehen Sie die angeklickete Fläche heraus noch mit der linken Maustaste festgehalten.



Um das Objekt noch weicher zu machen, benutzen Sie Aktion -> subdivide oder drücken Sie "s"



Um die Flächen zu verstecken, können Sie creaseAngle von IndexedFaceSet setzen.



Seien Sie sich bewusst, dass es kein "eckiger" Kommando in white_dune gibt ausser den "tessellation" Feldern in Nurbs(Patch)Surface or superformula basierten Knoten.



Deswegen ist es nützlich, oft edit -> undo zu benutzen um ein subdivided objekt zu testen and zu modifizieren.
Leider funktioniert Subdivide nicht mit allen Flächen, sondern nur mit geschlossenen Objekten. Deswegen ist Subdivide bei Auswahl eines SuperExtrusion Knotens ausgegraut.

Ändern von Coordinate basierten Knoten (neu in Version 0.29beta)

Seit Version 0.29beta können auch Coordinate basierte Knoten (wie IndexedFaceSet ("Mesh"), IndexedLineSet oder PointSet) genauso im 3D Preview Fenster interaktiv verändert werden wie die Kontrollpunkte eines NURBS Körpers.
Bei Knoten mit sehr vielen Punkten, ist das (noch) nur sinnvoll um kleinere Details zu verändern.

Umklappen/austauschen und Setze Drehpunkt Aktionen

Es gibt einige nützliche modelling Aktionen im Aktion Menü:

Array Werkzeug(new in Version 0.27beta)

White_dune erlaubt es Objekte zu vervielfälltigen. Im Unterschied zu ähnlichen Funktionen in einigen 3D-Modellers (wie dem "Art of Illusion" Programm) werden dabei nicht N Kopien des gleichen Objekts erzeugt. Es werden N VRML Transform Knoten (für Verschiebung (translation), Drehung (rotation), Vergrössern/Verkleinern (scale) und Mittelpunkt (scale) abhängig vom Arraydialog) mit einem VRML USE Konstrukt erzeugt. Ein USE Konstrukt ist ein kompakter Weg um Dinge in VRML zu wiederholen. Es ist eine Art "Zeiger ohne Unterschied", ähnlich wie ein Hardlink zu einer UNIX Datei (wenn Sie nur M$Windows kennen: eine cleverer Abart eines Shortcut zu einer Datei). Ein ge-USE-ter Knoten ändert sich ebenfalls, wenn sich das Orginal verändert.
Um das Array Werkzeug zu benutzen, muss das Objekt ausgewählt werden, das vervielfälltigt werden soll.



Danach wird der Menüpunkt Aktion -> Vervielfaeltigen benutzt. Im folgenden Array Dialog



kann die Zahl der Objekte (Numbers Objects) und die Parameter für die Transform Knoten eingetragen werden.



Wenn das Orginal geändert wird, ändern sich alle ge-USE-ten Knoten ebenfalls.



Reparatur-Kommandos im "Aktion" Menü

Die folgenden Kommandos sind nützlich, wenn man mit VRML/X3D Dateien arbeitet, die aus anderen Werkzeugen stammen. Sie dienen zur Korrektur von einigen kleineren Fehlern oder Problemen.

Weitere Kommandos im "Aktion" Menü

PROTO Erstellung/Veränderung

(new in Version 0.99pl444)

Um ein PROTO zu erstellen, muss zuerst ein Szenengraphzweig erstellt werden, deren Knoten den Grossteil des PROTOs ausmachen.
In diesem Beispiel sind ein Shape/Box, ein Shape/Sphere und ein Viewpoint Knoten in diesem Szenengraphzweig.



Um ein PROTO mit diesen Knoten zu erstellen, muss Actions->Rest of scenegraph branch->Move to->new PROTO angeklickt werden.




Es folgt ein Dialog, der nach dem Namen des PROTOs fragt, hier wählt man "DOME" (Kuppelgebäude)



Als nächstes folgt ein Dialog, der die Argumente des PROTOs bestimmt. An diesen Dialog kommt man später wieder mit Selektieren des PROTOs und Edit -> Object edit heran. Als field Argument wählt man SFColor color und drückt "Add".




Danach drückt man "ok" um den Dialog abzuschliessen.




Als nächstes öffnet sich das RouteView/IS-Fenster, dabei ist das PROTO "DOME" selektiert.



Es is jetzt möglich, die Knoten des PROTOs in den Szenengraph zu verschieben oder neue Knoten hinzuzufügen. In diesem Fall wird der Viewpoint Knoten aus dem PROTO in die normale Szene verschoben.
Als nächstes benutzt man Create -> PROTO usage -> DOME um den DOME im Szenengraph darzustellen.



Als nächstes selektiert man den einen Material-Knoten im PROTO und benutzt Routes/IS -> Show node on top .



Dananch verschiebt man Material-Knoten und PROTO im Route/IS view um color und diffuseColor zu verbinden.



Als nächstes selektiert man den anderen Material-Knoten im PROTO und benutzt Routes/IS -> Show node on top .



Dananch verschiebt man den anderen Material-Knoten und PROTO im Route/IS view um color und diffuseColor zu verbinden.



Danach lässt sich "color" im DOME-Knoten verändern und ein weiteres Transform und DOME Paar einfügen.



VrmlCut scripted Proto

(new in Version 0.29beta)

In VRML/X3D ist es erstaunlich schwierig eine Folge von Animationen zu erzeugen, die man ueblicherweise "Film" nennt. Passend zur Echtzeit 3D Natur von VRML/X3D koennen Animationen interaktiv und unabhaendig voneinander gestartet werden, deswegen ist es schwierig, eine allumfallende timeline (wie beim cutten eines Films) zu erzeugen.
Ein Ansatz, um das Problem in white_dune zu erleichtern ist die Benutzung des scripted PROTO Knoten VrmlCut. Dieser Knoten hat ein Field "scenes", in dem einzelne VRML/X3D Animationsdaten in einem anderen scripted PROTO Knoten namens VrmlScene abgelegt werden kann. Der Inhalt so eines VrmlScene Knoten kann man als Inhalt einer einzelnen Scene in einem Film ansehen. Der VrmlCut Knoten schaltet von einer VrmlScene zu der naechsten, versucht zur ersten Kamera(Viewpoint) zu springen und alle Animationen in der aktuellen VrmlScne zu starten.
Genau wie die SuperShape, SuperEllipsoid, usw. Knoten ist der VrmlCut Knoten ein eigentlicher VRML Knoten. Es ist ein PROTO, ein Verbund von VRML Knoten, er besteht aus einem Switch Knoten, einem Script Knoten und einem TimeSensor.
Genau wie ein Script Konten hat er einen Veraenderlichen Satz von fields/events. Weil mehrere VrmlCut Knoten mehrere verschiedene Saetze von fields/events haetten, can man nur eine Proto Definition von VrmlCut und deshalb nur ein VrmlCut Knoten pro VRML-file haben.
Der VrmlCut Knoten schaltet die Abfolge von VrmlScene Knoten (ein Group artiger Knoten mit einem Script Knoten fuer routing) angetrieben von TimeSenor und Script.
Alle Informationen zwischen VrmlCut, VrmlScene, TimeSensoren (fuer Animationen) und Viewpoints (Kameras) werden ueber ROUTE Verbindungen uebertragen. Das macht das Konzept flexibel (zum Beispiel koennen die ROUTE sourcen benutzt werden um andere Knoten wie Sound oder Fog zu versorgen), aber die Erzeugung von vielen Routes bedeutet viel Arbeit.
Um die Arbeit zu reduzieren, kann die folgende Methode benutzt werden:

Am Schluss kann man mit dem "play" icon oder ueber "Datei -> Vorschau the Kette von Animationen starten.
Mit den sceneNumber, numberPreviousScenes und numberNextScenes Fields des VrmlCut Knotens kann ein reduzierter Bereich der Animationen angeschaut werden. Das ist sinnvoll, um die Laengen der Scenen im sceneLengths field des VrmlCut Knoten zu optimieren.

Datei -> Upload

(new in Version 0.27beta)

White_dune hat einen Befehl (Menüpunkt Datei -> Upload) um eine VRML Datei auf einen Internet Server heraufzuladen.
Beim heraufladen einer Datei ins Internet wird man üblicherweise nach einem Passwort gefragt. White_dune kann das Passwort so speichern, dass es von den Auslagerungsdaten (swapspace) durch mlock/vlock Aufrufe geschützt ist.
Auslagerungsdaten ist der Inhalt von Computerspeicher der auf Platte ausgelagert wird um Platz für andere laufende Programme zu machen. Ein Eindringling kann die Auslagerungsdaten nach Passworten durchsuchen.
Die Übertragung eines Passworts von einer Anwendung (white_dune) zu einer anderen Anwendung (dem Herauflade-Kommando) auf einem sicheren Weg ist keine leichte Aufgabe, wenn man an Probleme wie die Auslagerungsdaten denkt.
Im upload settings dialog (Options -> Upload settings...)



kann das upload Kommando zwei Parameter haben. Jeder parameter der upload Kommandozeil wird mit Hilfe der Buchstaben "%s" gesetzt.

Die letzte Zeile im upload settings Dialog enthält die Möglichkeit, eine html-webpage nach dem Heraufladen aufzurufen. Um das zu nutzen, müssen die entsprechenden HTML tags eingetippt werden, die dann in ein HTML file eingetragen werden.
Zum Beispiel ist im folgenden Dialog eingetragen, dass die Daten aus white_dune in eine VRML Datei mit einem vorbestimmten Namen kopiert wird und dann diese VRML Datei zusammen mit der Zeichenkette "hello" im Webbrowser beim nächsten Datei -> Upload Kommando dargestellt wird.



Die Zeile mit den HTML tags kann "%s" einhalten, was dann durch das Passwort ersetzt wird. Dadurch wird ein HTML file mit einem Passwort erzeugt. Das ist ein sehr hohes Sicherheitsrisiko, benutzen diese Möglichkeit nicht, wenn Sie nicht genau wissen, was Sie tun !

*** Der Knotenvektoren ist der Vektor, über dem die NURBS-Kurve definiert ist. Ohne darauf näher einzugehen, soll nur kurz und beispielhaft sein Einfluß gezeigt werden. Betrachtet man den im Bild gezeigten Knotenvektor, so fällt auf, dass sich die ersten sowie die letzten Werte des Knotenvektors wiederholen. Das hat zu Folge, dass die Kurve wirklich bis zum ersten (letzten) Kontrollpunkt geht, und die erste (letzte) Seite des Kontrollpolygons (Polygon, dass durch die Kontrollpunkte gebildet wird) als Tangente besitzt, wodurch man bequem und "kontrolliert" modellieren kann (Man kennt die Endpunkte des Splines). Vervielfacht man Werte des Knotenvektors in seinem Inneren, so erzeugt man einen Stetigkeitabfall in der Kurve. Tritt ein Knoten so oft auf, wievielten Grades die Kurve ist, so kann man, wie im Bild zu sehen, eine Ecke in der Kurve erzeugen.